Sophora Specs

Alles über die Systemvoraussetzungen des Java-basierten CMS Sophora.

Sophora DeskClient: Editor und Vorschau
Sophora DeskClient: Editor und Vorschau (Bild: subshell/CC BY)

Sophora basiert auf innovativen, offenen Softwarestandards und erprobten Komponenten.

Sophora DeskClient (Aktuelle Version) – Desktop-Programm

Der Sophora DeskClient ist ein Java-Programm auf Basis des Eclipse-Frameworks, das lediglich Java benötigt, nur entpackt werden muss und nicht in das System eingreift. Ihr könnt den DeskClient manuell oder automatisch updaten.

  • Arbeitsspeicher: 1,5 GB freier, dedizierter Arbeitsspeicher oder mehr.
  • Festplattenplatz: 1 GB für das Installationsverzeichnis, zusätzlich Festplattenplatz für lokalen Cache.
  • Bildschirmauflösung: 1,920 x 1,080 Pixel oder mehr.
  • Schnelle Netzwerk- und Internetverbindung per HTTPS / Proxy.
  • Keine Administrationsrechte erforderlich.
  • Java: Wir liefern das passende Java gebundlet mit dem DeskClient.
  • Falls ein eigenes Java genutzt werden soll: Java mit JavaFX (Version 11 / 64 Bit oder neuer). Windows: Oracle JRE und ZuluFX, Mac: Oracle JDK und ZuluFX. Java muss mit allen Updates und Patches aktuell gehalten werden.

Mehr zum DeskClient.

Als vereinfachte Alternative oder Ergänzung zum DeskClient könnt ihr auch den browserbasierten Sophora MobileClient einsetzen.

Sophora Server (Aktuelle Version)

Der Sophora Server ist ein Stand-alone Java-Programm, an das eine externe Datenbank und Suchmaschine angeschlossen sind.

  • Betriebssystem: Red Hat Linux (x86, x86-64), openSUSE Linux (x86, x86-64), Solaris (Sparc, x86, x86-64), Debian (Version 9 oder neuer). Die Betriebssysteme müssen mit allen Updates und Patches aktuell gehalten werden.
  • Java 11 oder neuer (Oracle JDK und OpenJDK). Java muss mit allen Updates und Patches aktuell gehalten werden.
  • Externe Datenbanksysteme: Oracle (Version 10 oder neuer), MySQL (Version 5 oder neuer), Dateisystem.
  • Externe Systeme für die Vorschau und die Ausspielung: Apache HTTP Server (Version 2.4.0 oder neuer), Apache Tomcat (Version 7.0.62 oder 8.0.22).

Mehr zum Sophora Server.

07.12.20
Icon